Todoist integration partially broken
Incident Report for Reclaim
Resolved
This incident is resolved.

Todoist had an intentional "temporary blackout" on their v8 API which was root cause of this incident. This was scheduled for 10/17 from 14:00-18:00 UTC which is now over. We are monitoring but assumed Todoist/Reclaim users are no longer having issues. We are working through plans for the final v9 API upgrade scheduled for 10/31.
Posted Oct 17, 2022 - 20:29 UTC
Identified
Todoist has disabled their "v8" API ahead of their scheduled date of October 31st, causing the Reclaim/Todoist to unexpectedly break for anyone trying to establish a new Todoist connection via Reclaim's Settings -> Integrations page. Existing Todoist/Reclaim users do not seem to be impacted, but we are monitoring the situation and working on upgrading to the "v9" API ahead of schedule.
Posted Oct 17, 2022 - 16:45 UTC
This incident affected: Integrations (Todoist Integration).