The backlog has fully processed. We have determined that the core cause of today's incident was due to some (unrelated) database maintenance work we initiated yesterday, which began to have compounding impact on the specific Microsoft Outlook subsystem. We halted the maintenance work and will be exploring other ways to do that work in the future without causing a similar incident. Thank you for your patience as we worked through your Outlook calendar changes today.
Posted Mar 19, 2025 - 23:29 UTC
Monitoring
A fix has gone out and we are seeing the delayed work is getting processes. We anticipate we will be fully caught up with calendar sync changes in the next 1-2 hours. We will provide another update soon.
Posted Mar 19, 2025 - 22:32 UTC
Update
We are continuing to investigate and resolve the issue impacting delayed Outlook sync. We believe the issue impacts ~20% of the Outlook beta users. A potential fix is being deployed right now and we will continue to monitor the situation.
Posted Mar 19, 2025 - 17:05 UTC
Identified
We are seeing the delays on Microsoft sync decrease, but there are still some delays for some users. We are continuing to mitigate the issue.
Posted Mar 19, 2025 - 14:15 UTC
Investigating
We have received reports of delays in syncing in both directions for Microsoft Outlook. We're currently investigating the issue.
Posted Mar 19, 2025 - 12:52 UTC
This incident affected: Microsoft Outlook Calendar.