Google Calendar Sync Delays

Incident Report for Reclaim

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 19:48 UTC

Investigating

Some users may experience a delay on syncs to and from their Google calendars.
Posted Feb 11, 2026 - 17:18 UTC
This incident affected: Google Apps Calendar, Web Interface, Scheduler, and Calendar Sync.