Degraded Calendar Sync Performance

Incident Report for Reclaim

Resolved

The issue has been resolved, and calendar sync performance is back to normal.
Posted Mar 09, 2026 - 13:25 UTC

Identified

We’ve identified the issue, and service should return to normal shortly.
Posted Mar 09, 2026 - 13:07 UTC

Update

We are continuing to investigate this issue.
Posted Mar 09, 2026 - 12:53 UTC

Investigating

We’re currently experiencing degraded calendar sync performance. Some calendar updates may be delayed while we investigate and work on a fix.
Posted Mar 09, 2026 - 12:52 UTC
This incident affected: Calendar Sync.