Short maintenance
Incident Report for Reclaim
Resolved
The infrastructure upgrade has been complete. Thank you!
Posted Mar 25, 2021 - 01:10 UTC
Monitoring
We are upgrading some of our infrastructure, which may cause brief delays in our ability to process customer requests. If you experience any trouble, please try again. We expect this only to take a few minutes.
Posted Mar 25, 2021 - 01:01 UTC
This incident affected: Slack Integration, Web Interface, Scheduler, and Calendar Sync.