Verification is currently underway after the Database Upgrade
Posted May 03, 2025 - 18:20 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 03, 2025 - 17:33 UTC
Scheduled
We will be upgrading one of our Production Databases during this time. Some components of the platform, including calendar sync and the web planner may be unavailable for short periods of time.
Posted May 03, 2025 - 16:43 UTC
This scheduled maintenance affected: Google Apps Calendar, Web Interface, Slack Integration, Scheduler, Calendar Sync, Scheduling Links and Integrations (Zoom Integration, Todoist Integration, ClickUp Integration, Asana Intergation, Linear Integration, Jira Integration).