Google Calendar sync delays
Incident Report for Reclaim
Resolved
Issues with Google Calendar appear to have been resolved, and we have observed timely callbacks from Google for ~30min now. Calendar syncs for all users should be back to their normal response time, typically a few seconds.
Posted Oct 04, 2022 - 00:27 UTC
Update
Google Calendar continues to be behind on notifying us about calendar changes for most customers. We are continuing to monitor the situation.
Posted Oct 03, 2022 - 23:32 UTC
Monitoring
We are seeing signs of recovery, but it does not appear Google Calendar's issues are fully resolved.
Posted Oct 03, 2022 - 22:25 UTC
Identified
Google Calendar is experiencing a partial outage that is impacting all third-party SaaS services, such as Reclaim. The result is that they are not notifying Reclaim in a timely manner about changes to your calendar, resulting in delayed Calendar Sync and Habit/Task rescheduling behavior.

Typically, these outages resolve themselves after ~1hr or so, but we will keep you updated here as we see any improvements.
Posted Oct 03, 2022 - 21:51 UTC
This incident affected: Google Apps Calendar, Scheduler, and Calendar Sync.