Reclaim slow, inaccessible

Incident Report for Reclaim

Resolved

This incident has been resolved.
Posted Apr 06, 2025 - 23:57 UTC

Monitoring

The restore is complete and the application is now loading. The system will need to process changes from calendars and other integrations that happened during this outage. We will provide another update when all that work is complete. Until then, your schedule may appear to be a bit delayed.
Posted Apr 06, 2025 - 23:10 UTC

Update

We are in the middle of rolling back the database upgrade that led to this issue. Until that completes, new users will not be able to sign up and Reclaim will be inaccessible. We apologize for the inconvenience. We will provide another update shortly.
Posted Apr 06, 2025 - 22:27 UTC

Identified

We are aware that Reclaim is acting slowly or inaccessible to some people. A database maintenance we were attempting to do is having trouble. We are working on resolving this issue.
Posted Apr 06, 2025 - 21:44 UTC
This incident affected: Google Apps Calendar, Microsoft Outlook Calendar, Web Interface, Slack Integration, Scheduler, Calendar Sync, Scheduling Links and Integrations (Zoom Integration, Todoist Integration, ClickUp Integration, Asana Intergation, Linear Integration, Jira Integration).