Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 02, 2026 - 00:30 UTC
Scheduled
The Reclaim platform will be undergoing technical maintenance for approximately 60 minutes @ 4:30pm PST on 03-01-26.
Availability of the Web interface (planner), background services including calendar sync, scheduling links and integrations may be impacted.
There may be delays for calendar syncs, but no data will be lost.
Posted Mar 01, 2026 - 16:49 UTC
This scheduled maintenance affected: Google Apps Calendar, Microsoft Outlook Calendar, Web Interface, Slack Integration, Scheduler, Calendar Sync, Scheduling Links and Integrations (Zoom Integration, Todoist Integration, ClickUp Integration, Asana Intergation, Linear Integration, Jira Integration).