Slow and unresponsive web app
Incident Report for Reclaim
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 15:01 UTC
Monitoring
For the last 30-45 minutes, the Reclaim website has been slow and at times unresponsive. We have resolved the issue and are monitoring things to make sure they are 100% back to normal.
Posted Nov 09, 2020 - 14:42 UTC
This incident affected: Web Interface.